Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter · #1 ·
Had a problem with the 69...when turning headlights on,engine would lose all power...

Darrow,whom I just met a few weeks ago,drove 80 miles to my home today and fixed the problem....

I'll let Darrow explain...(he is on his way home now)..I'm going for a cruise !!!

Thanks Darrow....I owe you big time....:thumbsup:

Rich
 

·
Registered
Joined
·
3,584 Posts
Thats why I like this place:thumbsup:
 

·
Registered
Joined
·
5,916 Posts
Had a problem with the 69...when turning headlights on,engine would lose all power...

Darrow,whom I just met a few weeks ago,drove 80 miles to my home today and fixed the problem....

I'll let Darrow explain...(he is on his way home now)..I'm going for a cruise !!!

Thanks Darrow....I owe you big time....:thumbsup:

Rich
Now hold on here. Who set you two guys up?:WTF
 

·
Registered
Joined
·
658 Posts
Had a problem with the 69...when turning headlights on,engine would lose all power...

Darrow,whom I just met a few weeks ago,drove 80 miles to my home today and fixed the problem....

I'll let Darrow explain...(he is on his way home now)..I'm going for a cruise !!!

Thanks Darrow....I owe you big time....:thumbsup:

Rich
Rich you give me to much credit

It took booth of us to trace it out.

The problem was at the horn relay the clamp screws on the hot feed thru were loosing contact and this shut the whole system down.:buhbye:
 

·
Registered
Joined
·
5,916 Posts
Rich you give me to much credit

It took booth of us to trace it out.

The problem was at the horn relay the clamp screws on the hot feed thru were loosing contact and this shut the whole system down.:buhbye:
I always knew Rich had a screw loose.:laughing: Now, if you can just fix the loose nut behind the wheel.:rolling: :rolling:
 

·
Registered
Joined
·
237 Posts
Discussion Starter · #8 ·
Rich you give me to much credit

It took booth of us to trace it out.

The problem was at the horn relay the clamp screws on the hot feed thru were loosing contact and this shut the whole system down.:buhbye:
After spending 3 hours checking what seemed like everything, Darrow felt a wire running thru the horn relay...it was hot.....a screw was just 1/8 turn or so loose,and caused a break in the ground...that was it....:surprised

Rich
 

·
Registered
Joined
·
237 Posts
Discussion Starter · #10 ·
Thats why I like this place:thumbsup:
I was at my wits end.....this issue first came up in June....weird was if I jacked front end up,power came back....but if I turned headlights on,all power was lost to engine....very difficult to trace power when there is none...but Darrow was determined, and found the issue...
This forum is really great especially meeting guys like Darrow in person...Jeff (Big2bird) told me about Darrow,and we met on a Corvette run a few weeks ago....:thumbsup:
 

·
Registered
Joined
·
237 Posts
Discussion Starter · #12 ·
Certified nuts

:laughing: Not only do I have a screw loose,but got papers to prove it....:laughing:

Darrow: It was 101 F at our home yesterday...a new record for our area..:laughing:

Rich
 

·
Registered
Joined
·
658 Posts
Yea it was hot here today it must have got up to 80 and boy thats hot here think I WILL TURN ON THE AC

REALLY ENJOYED WORKING WITH YOU AND SAY HI TO THE WIFE
DARROW.
 
1 - 13 of 13 Posts
Top