Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
816 Posts
Discussion Starter #1 (Edited)
Just finished a heads/cam swap. Put in a tune to make it driveable and went out for a short drive around the block. Started hearing a pronounced tick. Babied it back, took off the valve covers, rechecked the torque on the rockers and tried it again. The noise returned but i noticed it wasn't there till oil pressure was around 35-40 psi.
Any ideas? Guess I'll have to pull the heads again, check to see if a lifter turned or collapsed. They are new LS7 lifters.
 

·
Registered
Joined
·
2,347 Posts
any updates on your car?
 

·
Banned
Joined
·
7,823 Posts
did you properly rotate the engine as you tightened the rocker arms? if not, some could be too preloaded and some not enough. also,does the ticking get worse as rpm increases? do the valvesprings have enough lift capability/spring rate for the cam?
 

·
Registered
Joined
·
816 Posts
Discussion Starter #4
The engine was rotated so that each cylinder i was working on both intake and exhaust were on base circle. The ticking was only present after the engine was warmed up and oil pressure was 35-40 psi.
I did alot of research and alot of measuring and rechecking. Came to the conclusion my pushrods were too short. Incorrect length pushrod is the most common valvetrain noise maker after a build.
As of now I'm waiting for the new pushrods to arrive.
 

·
Registered
Joined
·
3,516 Posts
Kool

What Heads/Cam Package did you go with ?

I'm listening

Bon
 

·
Registered
Joined
·
816 Posts
Discussion Starter #6
AFR 205s with the upgraded springs and a G5X3 cam.
 

·
Banned
Joined
·
7,823 Posts
im looking at that cam for the 402 ls2 im building this winter
 

·
Registered
Joined
·
3,516 Posts
im looking at that cam for the 402 ls2 im building this winter
Is the 402 A stroked LS2 Motor ?

That's gunna be a nasty little motor :devil:


Bon:laughing:
 

·
Banned
Joined
·
7,823 Posts
yea, its a stroked ls2....im putting trick flow 225cc cnc ported heads on it. im shooting for 600hp natural aspirated

i wanted a 427 ls3, but i cant justify spending another $900 for 25cid more.
 

·
Registered
Joined
·
5,146 Posts
yea, its a stroked ls2....im putting trick flow 225cc cnc ported heads on it. im shooting for 600hp natural aspirated

i wanted a 427 ls3, but i cant justify spending another $900 for 25cid more.
As far in as you are going and you are gonna skimp on 25 cid for $900? Do it you'll kick yourself later
 

·
Registered
Joined
·
816 Posts
Discussion Starter #12
Update

Changed the pushrods and the rockers. Started it up, after fixing an electrical gremlin, and went for a drive. Kept it civil, granny shifting. Car sounded and felt great. I was headed back, not a long drive, and it was just about warmed up and the ticking sound returned. Rockers are not contacting the valve covers, Pushrods were measured for correct length.

The only things left to check are the lifters themselves and the oil pump o ring. I'm leaning towards the o ring, since the sound it opposite of a collapsed lifter. I started it up today. Idled smooth and fine for a big cam. Revved it up a little, nothing. Got brave and took it gradually to 5k. Nothing. But after the oil temp reached 140ish the ticking returned.

So looks like the engines coming apart again.
 

·
Registered
Joined
·
175 Posts
My first thought when you said you changed the cam was did you change the lifters.

My guess is lifters especially if you changed the springs to something heavier than stock.

I always change the lifters when I do cam changes.
 

·
Registered
Joined
·
816 Posts
Discussion Starter #14
Lifters are brand new LS7s.
 

·
Registered
Joined
·
175 Posts
Hmmm.

OK, I haven't had to resort to this, but a friend recently had a similar lifter problem, but with an old car.
Someone recommended to use Shell Rotella oil.
It solved his problem.

Other than that, I'm out of ideas at this time other than is one of the new lifters bad or is there too much clearance in one or more of the lifter bores.

I'm new into these engines, but when I build an engine, I mic and check everything. I've seen bad cam lobes, bad lifters, etc. I hope it's something you find soon without too much more hassle.
 

·
Registered
Joined
·
3,516 Posts
Did you ever find a fix for your valve train noise ?
 

·
Registered
Joined
·
816 Posts
Discussion Starter #17
Did you ever find a fix for your valve train noise ?
Just finished it up tonight. Been busy lately at school starting new classes. My fiance and I spent 3 hours last night and 8 hours tonight on the tear down and reassembly. After, searching I had found that a faulty oil pump o ring could be the cause, especially witht the tick only occuring after it warmed up.

We tore it down and removed the oil pump and there was a decent sized chuck taken out oil part of the o ring. We replaced it and oil pressure was good at start up. After it warmed up, still nothing. Took it for a short drive. Cruising oil pressure was in the upper 50s. Just drove it home now. babied it the whole way since I havent broken it in yet. I hope to dyno it before it gets stored away for winter.
 

·
Registered
Joined
·
3,516 Posts
Just finished it up tonight. Been busy lately at school starting new classes. My fiance and I spent 3 hours last night and 8 hours tonight on the tear down and reassembly. After, searching I had found that a faulty oil pump o ring could be the cause, especially witht the tick only occuring after it warmed up.

We tore it down and removed the oil pump and there was a decent sized chuck taken out oil part of the o ring. We replaced it and oil pressure was good at start up. After it warmed up, still nothing. Took it for a short drive. Cruising oil pressure was in the upper 50s. Just drove it home now. babied it the whole way since I havent broken it in yet. I hope to dyno it before it gets stored away for winter.

Mann that's Awesome Dodd :nuts:

I'm glad it worked out for you

Cause it sure is a nice car

Bon
 

·
Registered
Joined
·
4 Posts
when the General says use only Mobil 1 5W30 synthetic and they thought about it enough to put it on the oil cap... Im going to stick with that
 

·
Registered
Joined
·
609 Posts
How loud was the clicking exactly? Got me curious now!
 
1 - 20 of 22 Posts
Top