Corvette Forum : DigitalCorvettes.com Corvette Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
issues with my '82 collector. I have had a full blown tune-up yet it seems when it warms up, it just stalls. even on the beltway doing 60 or so. I can put it in neutral and it starts right back up. But it cant be good on the starter or battery and it isnt dependable like this.

any ideas?
 

·
Premium Member
Joined
·
5,157 Posts
issues with my '82 collector. I have had a full blown tune-up yet it seems when it warms up, it just stalls. even on the beltway doing 60 or so. I can put it in neutral and it starts right back up. But it cant be good on the starter or battery and it isnt dependable like this.

any ideas?
We need some more data - I won't be back on here for a while, but here are some questions ...

If the engine is started cold, and allowed to idle until it reaches operating temperature, will it stall then? What is the actual temperature at which the stalling begins?

When it stalls (assuming you can answer the first question with a yes), are you reporting that it then restarts immediately? No long cranking, then a "reluctant" start? When you restart it, do you need to modulate the gas pedal, or will it start without it?

When you're going down the highway, and it stalls, and you restart it in neutral, how does it perform after that? Does it continue to stall, and you have to keep restarting it? How long between stall conditions?

If you shut it down when it gets up to operating temperature, can you restart it without any problems at that point?

We'll start here.

Steven
 
1 - 3 of 3 Posts
Top