Corvette Forum : DigitalCorvettes.com Corvette Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
My 04 LS1 has had several strange occurances with my gas gauge when I filled up. When I started the car the gauge went to empty and my check gauges light went on. The gauge tried to reset itself. Finally it cleared and went to full. It took about 15-20 miles to clear. No effect on performance was felt. This has happened on several occasions. I am running Sunoco w/o Ethenol. Any suggestions or comments.....? I have checked the gas cap and restarted the car. It still took a while to clear the system.
 

·
Premium Member
Joined
·
17,444 Posts
you cn try doing a search there have been many posts on this problem it has to do with the sender in the tank. maybe some one that has had the trouble will chim in here.
 

·
Registered
Joined
·
495 Posts
Hey I have the same problem every time a floor the gas pedal I see my gas gauge go down to empty really quickly:WTF just kidding:smack .I agree use Techron to clean up the sensors.this has helped the problem with mine.This is a common problem with the c5 vettes.My gauge does whatever it feels like.Sometimes its fine other times its up and down.Vettes Rule!!!!:partyon:
 

·
Registered
Joined
·
105 Posts
wow, I believe this just happened to me, My c5 was in the shop last week based on my car running out of gas when the gauge was reading I had 1/4 left. Can somebody help me out........I take my vet to a vet mechanic (corvette village) they put 1.5 gallons in and the gauge went to 1/3, then they went and filled it up with 14.5 gallons, so that means when it died on me it was at least 3 gallons left. So was this three gallons split between the tanks to make 1.5 each or all the gas in one of the them. And then yesterday as i'm approaching half a tank on the gauge my low fuel light and check guages comes on. I fill my car back up and it took 8.2 gallons. So the problem they told me I could be looking at now, is one of the pumps in the two tanks has went out and its a part gm doesn't make any more, so they may have to search around and get it from a salvage yard. Has anybody heard of one of the fuel pumps going out and somebody driving around with just a half tank available. I sure hope this is just a sensor problem, but it was wierd for my car to die with 3 gallons left. HELP!!!!:lookinup:


I'm talking about The pump inside of the two tanks to get gas right to left or left to right, however it works
 

·
Registered
Joined
·
46 Posts
That is wierd. My car was running fine (04 a4 coupe) then one day I had a fuel smell when I parked her for the day. I just filled up and figured I spilled some. Well for the next few weeks I had a constant fuel smell. One day in WalMart parking lot I was losing gallons of gas leaking out from the tank. I thought I bottomed out and maybe punctured my tank. Took it to the dealer and $1,800 later, they found my Tank seal went out and the gas would leak under pressure (on the top of the tank). WELL NOW when I drive, I swear I can see my gas gauge moving( I only go 7 miles to work and back - 14 miles a day tops) In 5 days I run through a half a tank....does that seem wierd to any of you? I did not remember my car being that bad on gas- actually my baby was pretty damn good in the fuel milage area! What do you guys think? Is my fuel gauge broken too?
 

·
Premium Member
Joined
·
155 Posts
It has happened to me about 7 times since 1998 on my 99 c5. I usually just pull over and turn off the car and re start it to fix it. I think alot of c5 corvettes have this problem, only 1 time has my car died because of this while i was driving.
 

·
Registered
Joined
·
745 Posts
Use Techron gas additive. A lot of people used this on a few fill ups and got the problem fixed, some people use Seafoam which I found in Menards. Unfortunately for some- the problem was so bad that they had to replace the gas tank sensors. I have an 03 which ran fine for about 4 years ( got mine in 9/02) until recently, my gas gauge would be on the last quarter and the next day it will show on the DIC that the tank is using the reserve fuel ( w/c is about 1-2 gals. left in the tank) and my gauge would be in the red marker - used techron gas additive twice and problem solved.:D
 
1 - 8 of 8 Posts
Top